Visokio website     Downloads     Video tutorials     KnowledgeBase  
SQL Server Connection Problem Running Scheduler on Windows 2008 Server R2 - Visokio Forums
SQL Server Connection Problem Running Scheduler on Windows 2008 Server R2
  •     bfromson January 17, 2011 11:02AM
    We are having a very strange SQL loging problem that has just cropped up with the scheduler on a new server.

    The new server is running Windows 2008 Server R2 Standard - other scheduler tasks we have run have been on Windows 2003 server or Windows 7 desktop.

    The error is in connecting to one of our SQL servers from the Win 2008 based machine - connections from 2003 and win 7 work just fine. The error message from the SQL server end is " Length specified in network packet payload did not match number of bytes read; the connection has been closed. Please contact the vendor of the client library. [CLIENT:]". The connection is then terminated and we can't access any data - unfortunately this is our main data source.

    Any ideas ???
  •     chris January 17, 2011 11:14AM

    Thanks for your question. Could you provide me with the following information:

    - How are you trying to download the data? Are you using Omniscope or DataManager?
    - What version of SQL server is running?
    - Which driver are you using? Have you tried both jTDS and SQL Server (both options are provided in the application)?
    - Do the errors occur when connecting to other SQLServer databases?
    - Can you create a DataManager bookmark to the Server? If so can it detect the tables on the DataBase?


  •     bfromson January 17, 2011 12:22PM

    - failure occurs with either Omniscope or DataManager,
    - connection is jTDS
    - only on this server and not on other apparently identically configured servers
    - Running SQL Server 2008
    - only when connecting from Windows 2008 R2, not 2003x64 or windows 7
    - connection to server works fine from within SQL Server Studio from same machine to same SQL server

    It may well be a server configuration problem, but just wondering if you had seen anything similar elsewhere and might be able to point us in the right direction
  •     chris January 17, 2011 1:43PM
    It sounds like it is a server configuration problem, but it would be worth trying to connect using the SQL Server 2008 driver instead of jTDS. Could you also submit the error message as a bug. You should be able to do this by clicking on the error message when executing it manually.

  •     steve January 17, 2011 2:22PM
    Could this be a proxy settings issue?
  •        mohamed January 17, 2011 3:37PM
    Could you please test disabling proxy server settings to check if it is a proxy issue or not as follows:

    1. Edit this file "C:\Program Files\Visokio Omniscope\" for 32 bit or "C:\Program Files (x86)\Visokio Omniscope\" for 64 bit.
    2. Replace this line
    with this one
    ADDITIONAL_JVM_ARGS=-Dvisokio.disableCustomProxySelector=true -DenableProxyDebug=true -Dvisokio.disableSystemProxies=true
    3. Save the file .
    4. Restart Omniscope.
    5. Connect to your database.
  •     bfromson January 24, 2011 7:33AM
    We have tried making the above change, and have changed the proxy server settings. The situation is now:

    There are three servers we try to access, all the servers are on the same subnet and all have the same SQL versions. Two of the servers still work fine. 

    Third server still fails with the message "I/O Error: DB server closed connection." 
    - however if you keep on clicking on the connect button it eventually gives a "connection successful" message and shows drop down list of tables and successfully retrieves data.

    Is there any debug version we can run that will give more information on why the connection is failing?

    Using the same id connecting between the same servers works just fine with SQL Server software, it works just fine with Omniscope with SQL Server authentication, it just doesn't work reliably with windows authentication.

  •     steve January 24, 2011 9:44AM
    So, to sum up, proxy server settings didn't help, it's a problem specific to a single box, which happens to be the only box running Windows Server 2008 R2?

    Does the problem appear to be caused by the PC originating the connection, or the database server?

    Have you tried using 3rd party software to connect to the database?

    Try following the suggestions here:

    Also try changing your Network security setting as follows (revert after testing):

    1.    Click Start,  then click Control Panel, and then click Administrative Tools.

    2.    Click Local Security Settings, expand Local Policies.

    3.    Click Security Options.

    4.    Double-click Network Security: LAN manager authentication level, and then click "Send LM & NTLM – use NTLMv2 session security if negotiated" value in the list.

    Please post your results back here.

  •     bfromson January 24, 2011 12:55PM
    Need to get server administrator to make that change. Will let you know tomorrow if it works.

  •     bfromson January 25, 2011 5:36AM
    We have now installed Omniscope version 2.5 on the server so that we can manually configure the jdbc connection - if we set the namedpipe parameter to true then the connection works

    use the jdbc url jdbc:jtds:sqlserver://;namedpipe=True

    is it possible to expose parameters and set them in 2.6?
  •     steve January 25, 2011 6:18AM
    Please post this as an idea and vote on it. Meanwhile, use "JDBC (Advanced)" in 2.6, which allows you to use the same 2.5 JDBC URL which you've clearly figured out from the 2.6 connector.


It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership